Minimum requirements for Using QuiqNest APP

Minimum requirements for Using QuiqNest APP

The following information describes the minimum requirements for using QuiqNest app on mobile and desktop browsers.Supported Tablet & Mobile Devices

iOS 11 or later
Android 4.4 or later

Supported Desktop & Browsers

Access QuiqNest from the web on your Windows or Mac using one of these supported browsers

Chrome 72+
Firefox 59+
Microsoft Edge (Chromium) 80+
Safari 12.2+
IE 11+

Minimum requirements for Using QuiqNest APP
Scroll to top